Fix Cydia Impactor: Installer.cpp:71 application installed as incompatible error

Provision.cpp:71 error is one of the most common errors that occur when using Cydia Impactor to sideload apps. The error is usually followed by the message: provision.cpp:71 ios/submit/DevelopmentCSR = 7469 You already have a current iOS Development certificate or a pending certificate request.

If you are encountering this error, this post will come in handy. We’ve listed down a couple of solutions that you should try out. Make sure to try out different methods as what works for one person may not necessarily work for you.

Ways to fix “Provision.cpp:71 error in Cydia Impactor

Here is a detailed explanation of the different ways of solving this error:

  1. Reinstall the app

The first solution is to remove the existing version of what you are trying to install and then reinstall it again.

For example, if you are trying to install a jailbroken Snapchat IPA, you would have to uninstall it before you reinstall it again.

Read Also: Fix Cydia Impactor stuck on verifying application

  1. Use the install package option

To use this method:

  • Launch Cydia Impactor on your PC or Mac
  • Open the Device menu
  • Select “Install Package”
  • Browse and select the IPA file you wish to sideload

If this method doesn’t work, then go to the next step.

  1. Delete the “Yalu” or “Match_Portal” app

If you have jailbroken your device using Yalu, you need to remove the jailbreak apps for the You already have a current iOS Development certificate or a pending certificate request error to disappear.

Open your device and find “Yalu” or “match_portal” app and delete. Afterwards, you can use Cydia Impactor to sideload the app you wanted to install.

  1. Revoke previous certificates

Revoking existing Apple developer certificates can help solve a variety of issues on Cydia Impactor including the cpp:71 error. To do this:

  • Launch Cydia Impactor on your Mac or PC
  • Highlight Xcode then click “Revoke Certificates”
  • Enter your Apple ID details
  • Wait for the process to complete

You should now be able to use Cydia Impactor without worrying about the cpp:71 error when sideloading apps. Make sure you are running it on a compatible device.

Read Also: Fix Cydia Impactor provision.cpp:173 app-specific password error

Add a Comment

Your email address will not be published. Required fields are marked *